Clever SSO experiencing issues

Incident Report for Imagine Learning

Resolved

This incident has been resolved.
Posted Nov 25, 2024 - 12:59 MST

Investigating

We have been notified by Clever that their service is degraded. For more information, please visit their status page https://status.clever.com
Posted Nov 25, 2024 - 12:12 MST