Student and educator experiences are slow to load
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Apr 12, 2022 - 10:31 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2022 - 09:05 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity; as well as, Imagine MyPath Legacy and Imagine Purpose Prep 6-12 users who launch their experience from the Edgenuity LMS.

Both students and educators are experiencing slower load times.

We apologize for the inconvenience and will provide an update soon.
Posted Apr 12, 2022 - 08:49 MST
This incident affected: Virtual School Services (Imagine Instructional Services), Courseware (Imagine Edgenuity), Academies (Edgenuity Virtual Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose Prep 6-12).