Imagine Math and Imagine Math Facts - roster failures

Incident Report for Imagine Learning

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 09:24 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2025 - 08:11 MST

Investigating

Our team is actively investigating an issue impacting users of Imagine Math and Imagine Math Facts.

Automated rostering calls are failing. New users are not being created, and existing users are not being updated.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 19, 2025 - 07:00 MST
This incident affected: Supplemental & Intervention (Imagine Math, Imagine Math Facts).