Imagine Language & Literacy and Imagine Español - Some Students Unable to Progress
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Apr 03, 2023 - 10:11 MST
Monitoring
Our team has implemented a solution. All students should be able to login and complete activities. We are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Apr 03, 2023 - 07:41 MST
Investigating
Our team is actively investigating an issue impacting some Imagine Language & Literacy and Imagine Español students. Some students are kicked out of their activities after they begin.

We apologize for the inconvenience and will provide an update soon.
Posted Apr 03, 2023 - 06:53 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español).