Middle School Twig Science issues affecting users
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted May 25, 2022 - 09:11 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted May 25, 2022 - 08:31 MST
Identified
Our team has identified the cause of the issue and are currently deploying a solution.

We will continue to update progress.
Posted May 25, 2022 - 08:22 MST
Investigating
We're currently investigating problems with our Middle School Twig Science platform. Users may be experiencing slow page loads, or content not appearing as expected. We're working hard on restoring service! We will update as we know more. Thank you for your patience!
Posted May 25, 2022 - 07:11 MST
This incident affected: Core Curriculum (Imagine Learning Twig Science).