Imagine Math - Students Unable to Open Lessons
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Apr 16, 2024 - 18:47 MST
Monitoring
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Apr 16, 2024 - 18:34 MST
Update
We are continuing to investigate this issue.
Posted Apr 16, 2024 - 18:17 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Math.

We have received reports that some students see a "something went wrong" message when attempting to access their lessons.

We apologize for the inconvenience and will provide an update soon.
Posted Apr 16, 2024 - 18:11 MST
This incident affected: Supplemental & Intervention (Imagine Math).