Imagine Language and Literacy and Español Users Experiencing Errors
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Aug 13, 2022 - 06:24 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2022 - 15:09 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 12, 2022 - 14:56 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Language and Literacy, Imagine Español, Imagine Reading, Imagine Galileo and Imagine Lectura.

Students and Educators are experiencing errors after logging in.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 12, 2022 - 14:13 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español, Imagine Lectura, Imagine Reading, Imagine Galileo).