Imagine Reading and MyPath Dictonary Lookups Failing
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted May 11, 2022 - 10:52 MST
Monitoring
Our team implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted May 11, 2022 - 08:17 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Reading and Imagine MyPath.

Students and Educators may experience dictionary lookups are coming back very slowly or not at all.

We apologize for the inconvenience and will provide an update soon.
Posted May 11, 2022 - 08:05 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Reading).