Twig Science Availability Incident

Incident Report for Imagine Learning

Resolved

The home page is now accessible. Thank you for your patience as we worked to resolve this issue.
Posted 2 years ago. May 29, 2023 - 07:26 MST

Investigating

Our home page www.twigscience.com is inaccessible, but the Twig Science K-6 and Middle School applications are still up and running. To access the affected products you can visit the applications directly:

Twig Science K-6: https://app.twigscience.com
Twig Science Middle School: https://ms.twigscience.com

We apologize for the inconvenience and will provide an update soon.
Posted 2 years ago. May 29, 2023 - 06:06 MST
This incident affected: Core Curriculum (Twig Science).