Twig Science - Assessments Not Loading for Students and Teachers

Incident Report for Imagine Learning

Resolved

This incident has been resolved.
Posted 2 years ago. Sep 20, 2023 - 02:54 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 2 years ago. Sep 20, 2023 - 00:40 MST

Identified

Our team has identified the cause of the issue, and we expect that the solution will be implemented by 6 AM ET tomorrow.
Posted 2 years ago. Sep 19, 2023 - 17:17 MST

Investigating

Our team is actively investigating an issue impacting users of Twig Science.

Students and educators cannot open assessments. They are presented with an error message.

We apologize for the inconvenience and will provide an update soon.
Posted 2 years ago. Sep 19, 2023 - 15:39 MST
This incident affected: Core Curriculum (Twig Science).