Imagine Edgenuity - Users Unable to Log In
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 17:46 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 17, 2022 - 14:45 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity, as well as Imagine MyPath Legacy and Imagine Purpose Prep 6-12.

Users cannot log in.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 17, 2022 - 14:07 MST
This incident affected: Courseware (Imagine Edgenuity), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).