Imagine Math Password Reset Page Not Loading
Incident Report for Imagine Learning
Resolved
The Imagine Math password reset page is now operational.
Posted Oct 17, 2019 - 13:09 MDT
Identified
A fix has been identified and is currently being tested.
Posted Oct 17, 2019 - 10:18 MDT
Investigating
We are currently investigating what is causing the Imagine Math password reset page to not fully load.
Posted Oct 17, 2019 - 09:21 MDT
This incident affected: Imagine Math (Math 3-8).