Imagine Assessment Service Degradation
Incident Report for Imagine Learning
Resolved
The Imagine Assessments platform is operational.
Posted Jan 07, 2020 - 11:22 MST
Investigating
The Imagine Assessments platform is currently in a degraded state. Wait times may be longer than expected and some requests may be failing. Our Operations team is currently engaged and investigating the issue. We apologize for the inconvenience.
Posted Jan 07, 2020 - 11:09 MST
This incident affected: Imagine Assessment (Galileo K-12, Galileo PreK).