Imagine Language and Literacy Outage
Incident Report for Imagine Learning
Resolved
The service has been restored and Language and Literacy is now fully operational again. Thanks again you for your patience.
Posted Jul 29, 2020 - 12:37 MDT
Identified
We have identified an issue with an underlying service that is causing an outage of Imagine Language & Literacy. We are actively working to resolve the issue and get a fix in place. We expect service to be restored within the next few moments. Thank you for your patience as we work to resolve this issue.
Posted Jul 29, 2020 - 12:35 MDT
This incident affected: Imagine Literacy (Language & Literacy).