Imagine Math Usage Report Accuracy Issue
Incident Report for Imagine Learning
Resolved
We have verified that the data is now accurate. This issue is now resolved.
Posted Aug 28, 2019 - 15:00 MDT
Investigating
On Monday, August 26th our teams discovered an issue impacting the accuracy of the Imagine Math Usage: Overview report. Our teams are working to resolve the issue.
Posted Aug 27, 2019 - 08:44 MDT
This incident affected: Imagine Math (Math 3-8).